$re = '/(?<!\b(?:soy|almond)\s*(?:milk)?)\bmilk\b/m';
$str = '"...almondmilk..." = no match
"...almond milk..." = no match
"...almond word(s) milk..." => matched [\'milk\']
"...almondword(s)milk..." => matched [\'milk\']
"...soymilk..." = no match
"...soy milk..." = no match
"...soy word(s) milk..." => matched [\'milk\']
"...soyword(s)milk..." => matched [\'milk\']
is combined with creamy soy and milk. a fruity and refreshing sip of spring,
is combined with creamy milk. a fruity and refreshing sip of spring,
"...milk...this is soy milk and regular milk" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);