import re
regex = re.compile(r"(?<!\b(?:soy|almond)\s*(?:milk)?)\bmilk\b", flags=re.MULTILINE)
test_str = ("\"...almondmilk...\" = no match\n"
"\"...almond milk...\" = no match\n"
"\"...almond word(s) milk...\" => matched ['milk']\n"
"\"...almondword(s)milk...\" => matched ['milk']\n\n"
"\"...soymilk...\" = no match\n"
"\"...soy milk...\" = no match\n"
"\"...soy word(s) milk...\" => matched ['milk']\n"
"\"...soyword(s)milk...\" => matched ['milk']\n\n"
"is combined with creamy soy and milk. a fruity and refreshing sip of spring,\n"
"is combined with creamy milk. a fruity and refreshing sip of spring, \n\n"
"\"...milk...this is soy milk and regular milk\" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")