package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\w*(?:and|the|or|which|on|about|movies|tomatoes|reddit|played)\w*`)
var str = `This question is a bore,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}