re = /\w*(?:and|the|or|which|on|about|movies|tomatoes|reddit|played)\w*/i
str = 'This question is a bore,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end