import re
regex = re.compile(r"\w*(?:and|the|or|which|on|about|movies|tomatoes|reddit|played)\w*", flags=re.IGNORECASE)
test_str = "This question is a bore,"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")