$re = '/\w*(?:and|the|or|which|on|about|movies|tomatoes|reddit|played)\w*/i';
$str = 'This question is a bore,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);