#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"([^"]+)""
Local $sString = "string(10) "CURITIBA" string(11) "SP"" & @CRLF & _
"fasdjask fsjkasjdklfklasdjflasdjklçfjasklç as"fasd fasd fasdasdfasdfasdfasdfasfasdfasdfasdfasfasdfasdfasdfasdfasdfasfsadfasdffas" fas asfd" & @CRLF & _
"" & @CRLF & _
"fasdfasdfjklasdfklçasdjklf jlasdjfklasdj klfj asdlkçfj klasdçfasd" & @CRLF & _
"" & @CRLF & _
"ESTA ASPAS NÃO FECHA: "fasdklfasdkljfklasjflkasjklfjasklfjasdklfjasfsdjklafjasdklfjklsadjfklasjlfjasdlfjaskljfklasjfasklçjkfasfsdafasdfasdfdlasdfdasfsdafadfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasfasdfasdfasdfasfasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")