import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"]+)\"";
final String string = "string(10) \"CURITIBA\" string(11) \"SP\"\n"
+ "fasdjask fsjkasjdklfklasdjflasdjklçfjasklç as\"fasd fasd fasdasdfasdfasdfasdfasfasdfasdfasdfasfasdfasdfasdfasdfasdfasfsadfasdffas\" fas asfd\n\n"
+ "fasdfasdfjklasdfklçasdjklf jlasdjfklasdj klfj asdlkçfj klasdçfasd\n\n"
+ "ESTA ASPAS NÃO FECHA: \"fasdklfasdkljfklasjflkasjklfjasklfjasdklfjasfsdjklafjasdklfjklsadjfklasjlfjasdlfjaskljfklasjfasklçjkfasfsdafasdfasdfdlasdfdasfsdafadfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasfasdfasdfasdfasfasd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}