#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+-]?\d+(?:\.\d*)?(?<!.{6})"
Local $sString = "123" & @CRLF & _
" -> 123" & @CRLF & _
"1.23" & @CRLF & _
" -> 1.23" & @CRLF & _
"123456" & @CRLF & _
" -> 12345" & @CRLF & _
"+12.34" & @CRLF & _
" -> +12.3" & @CRLF & _
"-12.34" & @CRLF & _
" -> -12.3" & @CRLF & _
"1.2-3" & @CRLF & _
" -> 1.2" & @CRLF & _
"1.2.3.4" & @CRLF & _
" -> 1.2" & @CRLF & _
"...."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")