using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?\d+(?:\.\d*)?(?<!.{6})";
string input = @"123
-> 123
1.23
-> 1.23
123456
-> 12345
+12.34
-> +12.3
-12.34
-> -12.3
1.2-3
-> 1.2
1.2.3.4
-> 1.2
....";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}