import re
regex = re.compile(r"^[+-]?\d+(?:\.\d*)?(?<!.{6})", flags=re.MULTILINE)
test_str = ("123\n"
" -> 123\n"
"1.23\n"
" -> 1.23\n"
"123456\n"
" -> 12345\n"
"+12.34\n"
" -> +12.3\n"
"-12.34\n"
" -> -12.3\n"
"1.2-3\n"
" -> 1.2\n"
"1.2.3.4\n"
" -> 1.2\n"
"....")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")