const regex = new RegExp('^[+-]?\\d+(?:\\.\\d*)?(?<!.{6})', 'gm')
const str = `123
-> 123
1.23
-> 1.23
123456
-> 12345
+12.34
-> +12.3
-12.34
-> -12.3
1.2-3
-> 1.2
1.2.3.4
-> 1.2
....`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}