$re = '/^(?:.*\bOptional\b.*\s=\s.*|(?!.*\bOptional\b).+)/m';
$str = 'Optional str1 as string = \'\'
str2 as string
str3 as boolean, Optional dtm as date = Now
str3 as boolean, Optional dtm as date Now';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);