re = /^(?:.*\bOptional\b.*\s=\s.*|(?!.*\bOptional\b).+)/m
str = 'Optional str1 as string = \'\'
str2 as string
str3 as boolean, Optional dtm as date = Now
str3 as boolean, Optional dtm as date Now'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end