import re
regex = re.compile(r"^(?:.*\bOptional\b.*\s=\s.*|(?!.*\bOptional\b).+)", flags=re.MULTILINE)
test_str = ("Optional str1 as string = ''\n"
"str2 as string\n"
"str3 as boolean, Optional dtm as date = Now\n"
"str3 as boolean, Optional dtm as date Now")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")