import re
regex = re.compile(r"(?:^|\n\d+\))[^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*(?:(?<=\D)\)|\([^)]*$)")
test_str = ("Текст текст текст. Список:\n\n"
"1) пункт первый\n"
"2) пункт второй\n"
"3) пункт третий\n"
"228) наркопункт\n"
"1337) элитный пункт\n"
" Текст (текст (в (скобках) ещё (текст) в) скобках) текст.\n"
"1488) наципункт\n\n"
"Скобкодаун тешится)))\n"
"Скобкодаун грустит(((")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")