import Foundation
let pattern = #"(?:^|\n\d+\))[^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*(?:(?<=\D)\)|\([^)]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Текст текст текст. Список:
1) пункт первый
2) пункт второй
3) пункт третий
228) наркопункт
1337) элитный пункт
Текст (текст (в (скобках) ещё (текст) в) скобках) текст.
1488) наципункт
Скобкодаун тешится)))
Скобкодаун грустит(((
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)