const regex = new RegExp('^user/([\\w-]+)/?$', 'gm')
const str = `user/John-Doe`;
const subst = `user?name=$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);