use strict;
my $str = 'user/John-Doe';
my $regex = qr~^user/([\w-]+)/?$~mp;
my $subst = 'user?name=$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";