$re = '~^user/([\w-]+)/?$~m';
$str = 'user/John-Doe';
$subst = "user?name=$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;