import Foundation
let pattern = #"^user/([\w-]+)/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"user/John-Doe"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"user?name=$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)