use strict;
my $str = 'SYS_FBA_TCRV_IDX1_36953
SYS_FBA_TCRV_36953';
my $regex = qr/(SYS_FBA_)([A-Z_])+?([A-Z_1-9])*_([0-9]{5,6})/mp;
my $subst = '\\1HIST_\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";