// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(SYS_FBA_)([A-Z_])+?([A-Z_1-9])*_([0-9]{5,6})").unwrap();
let string = "SYS_FBA_TCRV_IDX1_36953
SYS_FBA_TCRV_36953";
let substitution = "\\1HIST_\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}