using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^B\s]*(?:B{1,3}[^B\s]+)+B{0,3}|[^B\s]*B{1,3})$";
string input = @"sdBBdfsBBB
BfsBBBdsfBBB
aBBBaBBAaaabBBB
BBtestBBtestBBBtestBtestBBBtestBBBB
BB
test
aaBBB
B
BB
BBB
BBBB
aBBB
It shouldn't match:
fsBBBBsfBB
BBBBBfsBBBsd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}