use strict;
my $str = 'sdBBdfsBBB
BfsBBBdsfBBB
aBBBaBBAaaabBBB
BBtestBBtestBBBtestBtestBBBtestBBBB
BB
test
aaBBB
B
BB
BBB
BBBB
aBBB
It shouldn\'t match:
fsBBBBsfBB
BBBBBfsBBBsd';
my $regex = qr/^(?:[^B\s]*(?:B{1,3}[^B\s]+)+B{0,3}|[^B\s]*B{1,3})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}