package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^B\s]*(?:B{1,3}[^B\s]+)+B{0,3}|[^B\s]*B{1,3})$`)
var str = `sdBBdfsBBB
BfsBBBdsfBBB
aBBBaBBAaaabBBB
BBtestBBtestBBBtestBtestBBBtestBBBB
BB
test
aaBBB
B
BB
BBB
BBBB
aBBB
It shouldn't match:
fsBBBBsfBB
BBBBBfsBBBsd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}