using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Premiere XML has been exported to: ([^<>\n]+Adidas - Nite Jogger - 1080 -001 00_00_00-000(?:[^<>\n\.]|(?!\.xml))+\.xml)";
string input = @"File 1:
C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/a car in the desert
/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/
File 2:
C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000
/root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000
~~~~~~~~~~~~~~~
GOOD EXAMPLES
~~~~~~~~~~~~~~~
Premiere XML has been exported to: C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\\2023-03-09-1678381006-ICONO.xml']
Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml', '/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml
Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml
Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml
~~~~~~~~~~~~~~~
BAD EXAMPLES
~~~~~~~~~~~~~~~
WARNING: result_directRegex matched with: ['C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\\2023-03-09-1678381006-ICONO.xml']ory = 'C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/a car in the desert' is not present in xml_path = WindowsPath('C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381006-ICONO.xml')
AppActions.get_last_exported_xml_path(): xml_path = WindowsPath('C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381006-ICONO.xml')
Regex matched with: ['/root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml', '/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml']
INFO: result_directory = '/root/Desktop/ICONO SEARCH RESULTS/a car in the desert' is present in xml_path = PosixPath('/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml')";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}