import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Premiere XML has been exported to: ([^<>\\n]+Adidas - Nite Jogger - 1080 -001 00_00_00-000(?:[^<>\\n\\.]|(?!\\.xml))+\\.xml)";
final String string = "File 1:\n"
+ "C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/a car in the desert\n"
+ "/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/\n\n"
+ "File 2: \n"
+ "C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\n"
+ "/root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\n\n"
+ "~~~~~~~~~~~~~~~\n"
+ "GOOD EXAMPLES\n"
+ "~~~~~~~~~~~~~~~\n"
+ "Premiere XML has been exported to: C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\\\\2023-03-09-1678381006-ICONO.xml']\n"
+ "Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml', '/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml\n"
+ "Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml\n"
+ "Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml\n\n"
+ "~~~~~~~~~~~~~~~\n"
+ "BAD EXAMPLES\n"
+ "~~~~~~~~~~~~~~~\n"
+ "WARNING: result_directRegex matched with: ['C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\\\\2023-03-09-1678381006-ICONO.xml']ory = 'C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/a car in the desert' is not present in xml_path = WindowsPath('C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381006-ICONO.xml')\n"
+ "AppActions.get_last_exported_xml_path(): xml_path = WindowsPath('C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381006-ICONO.xml')\n\n\n"
+ "Regex matched with: ['/root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml', '/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml']\n\n\n"
+ "INFO: result_directory = '/root/Desktop/ICONO SEARCH RESULTS/a car in the desert' is present in xml_path = PosixPath('/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}