use strict;
my $str = 'File 1:
C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/a car in the desert
/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/
File 2:
C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000
/root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000
~~~~~~~~~~~~~~~
GOOD EXAMPLES
~~~~~~~~~~~~~~~
Premiere XML has been exported to: C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\\\\2023-03-09-1678381006-ICONO.xml\']
Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml\', \'/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml
Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml
Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml
~~~~~~~~~~~~~~~
BAD EXAMPLES
~~~~~~~~~~~~~~~
WARNING: result_directRegex matched with: [\'C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\\\\2023-03-09-1678381006-ICONO.xml\']ory = \'C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/a car in the desert\' is not present in xml_path = WindowsPath(\'C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381006-ICONO.xml\')
AppActions.get_last_exported_xml_path(): xml_path = WindowsPath(\'C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381006-ICONO.xml\')
Regex matched with: [\'/root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml\', \'/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml\']
INFO: result_directory = \'/root/Desktop/ICONO SEARCH RESULTS/a car in the desert\' is present in xml_path = PosixPath(\'/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml\')';
my $regex = qr/Premiere XML has been exported to: ([^<>\n]+Adidas - Nite Jogger - 1080 -001 00_00_00-000(?:[^<>\n\.]|(?!\.xml))+\.xml)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}