# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Premiere XML has been exported to: ([^<>\n]+Adidas - Nite Jogger - 1080 -001 00_00_00-000(?:[^<>\n\.]|(?!\.xml))+\.xml)"
test_str = ("File 1:\n"
"C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/a car in the desert\n"
"/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/\n\n"
"File 2: \n"
"C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\n"
"/root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\n\n"
"~~~~~~~~~~~~~~~\n"
"GOOD EXAMPLES\n"
"~~~~~~~~~~~~~~~\n"
"Premiere XML has been exported to: C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\\\\2023-03-09-1678381006-ICONO.xml']\n"
"Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml', '/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml\n"
"Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml\n"
"Premiere XML has been exported to: /root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml\n\n"
"~~~~~~~~~~~~~~~\n"
"BAD EXAMPLES\n"
"~~~~~~~~~~~~~~~\n"
"WARNING: result_directRegex matched with: ['C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000\\\\2023-03-09-1678381006-ICONO.xml']ory = 'C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/a car in the desert' is not present in xml_path = WindowsPath('C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381006-ICONO.xml')\n"
"AppActions.get_last_exported_xml_path(): xml_path = WindowsPath('C:/Users/Adrien/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381006-ICONO.xml')\n\n\n"
"Regex matched with: ['/root/Desktop/ICONO SEARCH RESULTS/Adidas - Nite Jogger - 1080 -001 00_00_00-000/2023-03-09-1678381652-ICONO.xml', '/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml']\n\n\n"
"INFO: result_directory = '/root/Desktop/ICONO SEARCH RESULTS/a car in the desert' is present in xml_path = PosixPath('/root/Desktop/ICONO SEARCH RESULTS/a car in the desert/2023-03-09-1678381686-ICONO.xml')")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.