#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\d( |-){0,1}){8}\d([A-Za-z])\b"
Local $sString = "11 22 33 44 5 T 11-----2233445T" & @CRLF & _
"" & @CRLF & _
"800-555-1212 When" & @CRLF & _
"800-555-1212W hen" & @CRLF & _
"800-555-1212 W hen" & @CRLF & _
"800-555-1212W hen" & @CRLF & _
" start00-555-1212W hen" & @CRLF & _
"00-555-1212W hen" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")