// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d( |-){0,1}){8}\d([A-Za-z])\b").unwrap();
let string = "11 22 33 44 5 T 11-----2233445T
800-555-1212 When
800-555-1212W hen
800-555-1212 W hen
800-555-1212W hen
start00-555-1212W hen
00-555-1212W hen
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}