import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d( |-){0,1}){8}\\d([A-Za-z])\\b";
final String string = "11 22 33 44 5 T 11-----2233445T\n\n"
+ "800-555-1212 When\n"
+ "800-555-1212W hen\n"
+ "800-555-1212 W hen\n"
+ "800-555-1212W hen\n"
+ " start00-555-1212W hen\n"
+ "00-555-1212W hen\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}