$re = '/\b(\d( |-){0,1}){8}\d([A-Za-z])\b/m';
$str = '11 22 33 44 5 T 11-----2233445T
800-555-1212 When
800-555-1212W hen
800-555-1212 W hen
800-555-1212W hen
start00-555-1212W hen
00-555-1212W hen
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);