using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^ *) ";
string substitution = @"_";
string input = @" something is here";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}