$re = '/(?<=^ *) /';
$str = ' something is here';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;