use strict;
my $str = ' something is here';
my $regex = qr/(?<=^ *) /p;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";