using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*?'(.*?)'\s*?=>\s*?(.*?),";
string substitution = @"$placesInOrder[$placesCount]->$1 = $2;\n";
string input = @" 'id' => $place->{'places.id'},
'status' => 0,
'brondta' => $jdate->toSql(),
'surname' => $place->{'places.surname'},
'first_name' => $place->{'places.first_name'},
'middle_name' => $place->{'places.middle_name'},
'sex' => $place->{'places.sex'},
'birth' => $place->{'places.birth'},
'document_type' => $place->{'places.document_type'},
'document_number' => $place->{'places.document_number'},
'document_country' => $place->{'places.document_country'},
'modified_by' => $juser->id,
'modified_time' => $jdate->toSql(),
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}