// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*?'(.*?)'\s*?=>\s*?(.*?),").unwrap();
let string = " 'id' => $place->{'places.id'},
'status' => 0,
'brondta' => $jdate->toSql(),
'surname' => $place->{'places.surname'},
'first_name' => $place->{'places.first_name'},
'middle_name' => $place->{'places.middle_name'},
'sex' => $place->{'places.sex'},
'birth' => $place->{'places.birth'},
'document_type' => $place->{'places.document_type'},
'document_number' => $place->{'places.document_number'},
'document_country' => $place->{'places.document_country'},
'modified_by' => $juser->id,
'modified_time' => $jdate->toSql(),
";
let substitution = "$placesInOrder[$placesCount]->$1 = $2;\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}