#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(password["',=]+)[^"',]+(["',]*)"
Local $sString = "{" & @CRLF & _
" "Env": [" & @CRLF & _
" "RELEASE_CHANNEL=stable"," & @CRLF & _
" "PASSWORD=qwerty!@#$%*^&()-_=+~<>.:;?/\|QWERTY"," & @CRLF & _
" "LOG_LEVEL=info"," & @CRLF & _
" "NODENAME=mynode"," & @CRLF & _
" "PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"" & @CRLF & _
" ]," & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")