using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(password[""',=]+)[^""',]+([""',]*)";
string input = @"{
""Env"": [
""RELEASE_CHANNEL=stable"",
""PASSWORD=qwerty!@#$%*^&()-_=+~<>.:;?/\|QWERTY"",
""LOG_LEVEL=info"",
""NODENAME=mynode"",
""PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin""
],
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}