using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"is\s(.+?),|([0-9].+)\.";
string input = @"Hello my name is John Doe, I'm 30 years old.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}