$re = '/is\s(.+?),|([0-9].+)\./m';
$str = 'Hello my name is John Doe, I\'m 30 years old.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);