package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)is\s(.+?),|([0-9].+)\.`)
var str = `Hello my name is John Doe, I'm 30 years old.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}