re = /is\s(.+?),|([0-9].+)\./m
str = 'Hello my name is John Doe, I\'m 30 years old.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end