using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^id=abc(?:(?!value=).)*value=1";
string input = @"id=abc somethingelse value=1 value=2 value=3 value=1
String not to be matched:
id=abc somethingelse value=2 value=2 value=3 value=1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}