$re = '/^id=abc(?:(?!value=).)*value=1/m';
$str = 'id=abc somethingelse value=1 value=2 value=3 value=1
String not to be matched:
id=abc somethingelse value=2 value=2 value=3 value=1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);