import re
regex = re.compile(r"^id=abc(?:(?!value=).)*value=1", flags=re.MULTILINE)
test_str = ("id=abc somethingelse value=1 value=2 value=3 value=1\n"
"String not to be matched:\n\n"
"id=abc somethingelse value=2 value=2 value=3 value=1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")