package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(?:(\d{3}\.\d{3}\.\d{3}-\d{2})|(\d{2}\.\d{3}\.\d{3}\/\d{4}-\d{2}).*?((?-2))).*?$`)
var str = `MARKET S.A.|41.355.058/0001-35| |123,45
MARKET S.A.|41.355.058/0001-35|681.538.156-01|123,45
MARKET S.A.|41.355.058/0001-35|70.092.275/0001-88|123,45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}