$re = '/^.*?(?:(\d{3}\.\d{3}\.\d{3}-\d{2})|(\d{2}\.\d{3}\.\d{3}\/\d{4}-\d{2}).*?((?-2))).*?$/m';
$str = 'MARKET S.A.|41.355.058/0001-35| |123,45
MARKET S.A.|41.355.058/0001-35|681.538.156-01|123,45
MARKET S.A.|41.355.058/0001-35|70.092.275/0001-88|123,45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);